Bad network and OPUS config

vocdot

New Member
Jul 16, 2020
7
0
1
I'm using opus@8000h@20i, but with bad network the call quality is bad.

if I call another extension and I simulate a packets loss of 15%, I hear good sound, but the called hears badly.

My Opus conf:
Code:
<settings>

  <param name="asymmetric-sample-rates" value="1"/>

  <param name="use-vbr" value="1"/>

  <param name="use-dtx" value="0"/>

  <param name="complexity" value="10"/>

  <param name="packet-loss-percent" value="20"/>

  <param name="keep-fec-enabled" value="1"/>

  <param name="use-jb-lookahead" value="1"/>
                                                                            
  <param name="maxaveragebitrate" value="0"/>

  <param name="maxplaybackrate" value="0"/>

  <param name="sprop-maxcapturerate" value="0"/>

  <param name="advertise-useinbandfec" value="1"/>

  <param name="adjust-bitrate" value="1"/>

  <param name="bitrate-negotiation" value="1"/>

</settings>


I've enabled JitterBuffer:
Code:
jitterbuffer_msec=60:120:

rtp_jitter_buffer_plc=true

rtp_jitter_buffer_during_bridge=true

suppress_cng=true

Have you any suggestions?