SOLVED Cannot avoid transcoding

Status
Not open for further replies.
Hi guys,

I've investigated many hours and cannot solve this problem:
A and B should use g711u.
A: 1541525574275.png

B: 1541525488336.png

But FreeSwitch decides to transcode:

1541525347168.png
The settings:
vars.xml
<X-PRE-PROCESS cmd="set" data="media_mix_inbound_outbound_codecs=false"/>
<X-PRE-PROCESS cmd="set" data="global_codec_prefs=OPUS,G722,PCMU,PCMA,VP8"/>

internal.xml
<param name="inbound-codec-negotiation" value="greedy"/>
<param name="inbound-late-negotiation" value="true"/>
<param name="disable-transcoding" value="true"/>

<param name="inbound-proxy-media" value="false"/>
<param name="inbound-bypass-media" value="false"/>
<param name="inbound-codec-prefs" value="$${global_codec_prefs}"/>
<param name="outbound-codec-prefs" value="$${global_codec_prefs}"/>

default.xml (Using the demo-Dialplan)
<extension name="Local_Extension">
...

Using FS v 1.8

Thank you.
Uli
 

Attached Files:

As far as i know, I may be wrong but freeswitch, fusion and handsets use codec's in written order, so above i can see Opus, G722 then G711 U and G711 A. so put them in the correct order on both phones, fusion and with your termination and you wont transcode.

"global_codec_prefs=PCMU,PCMA,OPUS,G722,VP8"/>

Hope that makes sense.
 
Status
Not open for further replies.