cluster, subscribe not working on failover

I have a two noded cluster, but when I test the failover (stop freeswitch on one node) the phone re-register with the other node and make/receive calls. The lights turn off like the phones don't send there state anymore. If I turn freeswitch back on, the phone find the first server and the "state" comes back and the lights come back on.

What am I missing?

I assume its not a phone issue but a freeswitch config since my yealink and grandstream phone does the same thing.
 
For switch to the second node, you need to turn off the first node. Then the ip address will go to the second node.
Turning off the service FreeSWITCH does not give the desired result.
 
I assumed that when the phone re-registered with the new server that it was also the subscribe. The phone needs to also have short timeout on the subscribe.

You would think the grandstream/yealink phones would have the sense to re-subscribe the the server that are registered/subscribe to is gone. but its a separate time setting.
 

DigitalDaz

Administrator
Staff member
I assumed that when the phone re-registered with the new server that it was also the subscribe. The phone needs to also have short timeout on the subscribe.

You would think the grandstream/yealink phones would have the sense to re-subscribe the the server that are registered/subscribe to is gone. but its a separate time setting.
Very good point, I had completely forgotten that for years!!