Direct Dial doesn't work in IVR

Status
Not open for further replies.

daddydrazen

New Member
Nov 7, 2022
19
0
1
43
Hello everybody,

I have a problem with the IVR dial direct. I have couple of extensions and couple of options in IVR menu. Client wants that caller can dial extensions directly (if know extension) so I enabled Direct Dial.

1677456157984.png

When I try to dial any existing extension destination is always ext #102. I figured out it is like that because it is option 1 and fusionPBX take only first digit of the 3 extension digits and that's why my calls always end up on 102 extension.
As you can see I even tried adding full extension # in option list but results is same.

I have red somewhere that this wont work if you have extension that starts with same digit as some of the options in the options list.
Then I tried to add extension that doesn't start with any digits from the option list so I added extension 500. When I tried to direct dial ext 500 I get "invalid entry" error.
But I watched a video on YT where some guy have option 1 and extension 1000-1005 and he is able to dial extensions.

Did any of you had similar issues? I don't know what else to do.

And I forgot to add that Digit Length is set to 3.

If anybody have some insight I would be very grateful. Thanks for any help.

Regards
Drazen
 

Attachments

  • 1677456121961.png
    1677456121961.png
    61.7 KB · Views: 9

daddydrazen

New Member
Nov 7, 2022
19
0
1
43
I figured out what's wrong. I used softphone for testing and it looks like softphone doesn't send DTMF properly or it sends just first digit, because any of the chosen options end up on proper destinations. I used Zoiper and EyeBeam for testing. Don't know how other sofpthones would behave. Maybe I will try.

In the end I tried with deskphone. Everything works as it should work. I tried couple of times direct dialing different extensions and some of the options too and it's all working normally.

Now following question is what can I do with these DTMF and sofphones in order to make this working properly? Any suggestions?

Regards
Drazen
 
Jan 9, 2018
152
15
18
54
Usually, there is a way to set the DTMF options to one of three settings: inband, RFC-2833, or SIP info. It maybe that the default setting isn't working with your config. I would try switching it and see if that helps. On Zoiper mobile (iOS) it's under Settings, Accounts, Features.
 

daddydrazen

New Member
Nov 7, 2022
19
0
1
43
Usually, there is a way to set the DTMF options to one of three settings: inband, RFC-2833, or SIP info. It maybe that the default setting isn't working with your config. I would try switching it and see if that helps. On Zoiper mobile (iOS) it's under Settings, Accounts, Features.
Thanks man, I just figured out that I can change these in SIP profiles on FusionPBX. I will try different variations to see what will happened. I can hardly influence on phones that callers will use when when inbound call occur but I can try with these changes on a server side (I can try changing these on my Zoiper but that's it).

Thank you once again man, you gently pushed me in a right direction. I will try and will post results here.
 
Jan 9, 2018
152
15
18
54
I don't have any experience with changing this in the SIP profiles. Usually the defaults "just work" on most phones. I'd be careful changing the profiles.

For softphones, we primarily use Groundwire, Grandstream Wave Lite, and sometimes, Zoiper, and we've never had to change DTMF settings on those. We do have to sometimes walk a customer through changing settings on their softphone to make it work, though (like maybe TCP/UDP transport), so you probably can just explain it as a compatibility setting.
 
Status
Not open for further replies.