Grandstream GXP2170, "No dial plan rules matched" | inbound call history redial

Hi PBXForums community!

I'm having some trouble dialing from the inbound call history on a Grandstream GXP2170. When I try, it displays an error "No dial plan rules matched" I've attached a picture of the error on the phone for reference. I can call out using a full 10 digit number, but it gives me the attached error when using the inbound history to return calls.
So far i've tried :
  • Enabling dialplan-bypass for 'call history outgoing call'
  • adding a dialplan entry on the GXP2170, something like '\+1x+', but the phone would unregister the line after I saved.
I thought I'd pose the question here before I got too far banging my head against the wall, as you all have been super helpful to me before with these types of things. Thanks in advance for the guidance and expertise!

Respectfully,

aitp/nadmin
 

Attached Files:

Either of the things you say you tried should have done the trick.
Another option is to modify the incoming CID number to strip the offending digits before the phone sees them.

caller_id_number=${regex(${caller_id_number}|^\+1([0-9]{10})$|%1)} will strip the “+1” if present.

This would need to be added to the dial plan somewhere such as “caller-details”
 
@ad5ou,

Thanks for the regex snippet! I have applied it to the caller-details inbound dialplan. I tested it with my yealink phone at home and it still shows a +1 in front of the number when I call in. I do see a change in caller_id_number in my cdr app data though, so im hopeful that the grandstream will be able to do it. Thanks again for the help and guidance. I'll post back when I test the Grandstream.

Respectfully,

aitp/nadmin