Help with Twilio SIP Trunk on FusionPBX 4.5

agile

New Member
Oct 21, 2020
20
2
3
39
Hi Guys I am struggling to setup Twilio trunk configuration on fusionpbx any help will be greatly appreciated.

I have setup Gateway as following
Gateway: Twilio

Username; usernamefortwilio
Password: passwdfortwilio

From User: left empty
From Domain: left empty

Proxy: something.pstn.twilio.com
Realm: left empty
Expire Seconds: 800
Register: True
Retry Seconds: 30

Context: public
Hostname: left empty

Enabled: False
Description: left empty

Any idea what I did wrong?
I can share screenshots of inbound and outbound too.

Appreciate if anyone can give some guidance.
 

Acer76e

New Member
Apr 24, 2020
2
1
3
35
Lakeland, FL, USA
www.callbreezy.com
Good morning, a few things that I can tell you seem incorrect that you'll want to check:

1. "From User" - this should be your associated phone number within Twilio, example 15559231234 (include the 1, don't include any + or dashes)
2. Enabled: This should be set to TRUE.

Try those two updates, and then see if you're still having issues with getting a REGED status.
 
  • Like
Reactions: agile

UCtech

New Member
Jan 9, 2019
14
3
3
If you haven't already you'll need to set up the inbound Twilio gateways from these IP addresses:
There are 4 east coast and 4 west coast. Calls can come through any of them, so you need to set them all up (and/or International as well). Twilio has great redundancy but this requires a bit more work to set up. As for each field:
Gateway: Descriptive Name -- might want to name each IP gateway with something that helps you to identify/differentiate each, like TwilOregon1
User Name & Password: Depends on how you set up your Twilio -- if you use no auth but your IP's then put bogus info in each field (I think Fusion will not let you leave them blank). Otherwise, put the auth that Twilio gave you in the Trunk settings.
Proxy: IP address from the link above corresponding to which Twilio link you are setting up.
Register: False if not using auth, True if yes, depending on your Twilio settings
Enabled: True
That's all for inbound normally.

Outbound Gateway setup:
Same as above except for the Proxy. Use DomainNameThatTwilioProvides.pstn.twilio.com

Hope that helps
 
  • Like
Reactions: agile

agile

New Member
Oct 21, 2020
20
2
3
39
Thanks for your help guys. Finally, I got this to work I will post all the screenshots to make it easy for others soon.
 

zero48

New Member
Mar 26, 2021
10
1
3
54
Thanks for your help guys. Finally, I got this to work I will post all the screenshots to make it easy for others soon.
Hello, Can you post the screenshoots I would like to add a Twilio to my fusionpbx... thanks in advance
 

agile

New Member
Oct 21, 2020
20
2
3
39
Hello, Can you post the screenshoots I would like to add a Twilio to my fusionpbx... thanks in advance
Here you go a couple of points
keep an eye on the Twilio debug if you get any errors
Twilio will not allow you to snd outbound calls if you do not have the number from them or present the number to them with Outbound Caller ID Number
always for outbound add +1 I have screenshots for you understand how i did it.
 

Attachments

  • twilio trunk Gateway setup.PNG
    twilio trunk Gateway setup.PNG
    27.3 KB · Views: 7
  • inbound Twilio.PNG
    inbound Twilio.PNG
    9.6 KB · Views: 7
  • outbound Twilio.PNG
    outbound Twilio.PNG
    25.5 KB · Views: 7
  • Like
Reactions: FuncVOIP and zero48