SOLVED Default Settings since update 5.3.1

wouam31

Member
Jul 1, 2022
83
12
8
40
Good morning,

I have been experiencing a problem for a very short time, the Default Settings of the domains (especially for provisioning) no longer work.
In the configuration file I find the global Default Settings.

The only change I was able to make is updating from 5.2 to 5.3.

Am I the only one having this problem?

Thank you so much
 

markjcrane

Active Member
Staff member
Jul 22, 2018
462
165
43
49
The code for how this is handled is now using a settings class. Please update to the very latest 5.3 version on the master branch.

Then try it again and report back. If you confirm you are on the latest version and still having the problem then I'll take a look at the code again.
 

johnny

New Member
Apr 10, 2020
12
2
3
39
Im on the latest master release as of 2024-07-02 and im having a similar issue. When I reboot my phones it fails to provision phone the polycom phones now show Invalid provisioning details Provisioning failed. The Timezone has been reset back UTC 0 and some other settings dont seem to work either anymore. To note I also was on 5.2 and then updated to master
 
Last edited:

johnny

New Member
Apr 10, 2020
12
2
3
39
I logged into the the Web UI of FusionPBX and clicked devices, then clicked on a device, clicked on files and tried to download the cfg file from the web ui but when i do so i get a page that says unauthorized. Are you getting the same thing with the latest master 5.3.1 update @wouam31

the uri it redirect me to is
https://sip.REDACTEDDOMAIN.com/app/provision/index.php?address=64247a26a33e&file={$mac}.cfg&content_type=application/octet-stream

but just says unathorized. I would think I would be authorized since im logged in as an admin. This could be possibly the reason why devices are not provisioning successfully
 
  • Like
Reactions: vuthy09

wouam31

Member
Jul 1, 2022
83
12
8
40
Hi @johnny ,

I am able to download the provision files on the web page.

On the other hand, the files are missing information which is in the default settings of the domain.
But there are general default settings.
 

vuthy09

Member
Jun 12, 2023
86
1
8
40
I logged into the the Web UI of FusionPBX and clicked devices, then clicked on a device, clicked on files and tried to download the cfg file from the web ui but when i do so i get a page that says unauthorized. Are you getting the same thing with the latest master 5.3.1 update @wouam31

the uri it redirect me to is
https://sip.REDACTEDDOMAIN.com/app/provision/index.php?address=64247a26a33e&file={$mac}.cfg&content_type=application/octet-stream

but just says unathorized. I would think I would be authorized since im logged in as an admin. This could be possibly the reason why devices are not provisioning successfully
I got the same error, unauthorized
 

wouam31

Member
Jul 1, 2022
83
12
8
40
Hi!

When I try to download for the first time, it asks me for the information I entered:
http_auth_username
http_auth_password

and then I can download the files.
 
  • Like
Reactions: vuthy09

wouam31

Member
Jul 1, 2022
83
12
8
40
Hi!

It's weird...
We're going to wait for @markjcrane to give us more information.

I saw that there were changes on Friday, I tested it yesterday and it didn't change the problem.

Patience ...
 
  • Like
Reactions: vuthy09