IVR with external transfer call

Status
Not open for further replies.

michelerizzo88

New Member
Mar 11, 2019
18
0
1
36
I have an incoming route to an ivr and if i select 1 or 2 the call is transferred to an external mobile number. Is it possible to receive the call with the original calling number instead of the number configured for the outbound route? Es: i call the number 11111 from 222222 and if i select 1 the call is transfered to 333333, but when the call is transfered 333333 see the number 222222 instead 11111. Is possibile this configuration?
Thanks
 

voipBull

Member
Dec 3, 2023
53
8
8
Isn't that the default behavior when a external number is dialed from an IVR, the original caller's caller ID name and number is used on the outbound call to external number.

What version of FusionPBX are you running?
How are you dialing the external number from the IVR?
Can you share the freeswitch logs and SIP trace of this call?
 

michelerizzo88

New Member
Mar 11, 2019
18
0
1
36
Hi, i'm using the 4.4.9 version of FusionPbx.
I have a SIP gateway and in destination i set ivr with 2 options: 1 - for extension 201 and 2 for extension 202.
I configure call forward on call routing for extension 202 to mobile number 346******** (extension isnot registered, but configured just to transfer call). the call is trasfered but i see the number of gateway and not the original caller id.
From sngrep there is from with original caller id, but with <sip:numberOfGateway> and in remote party ID original caller id.
I screenshot the outbound route configuration of my gateway and the sip trace with sngrep.
 

Attachments

  • sngrep.png
    sngrep.png
    76.5 KB · Views: 6
  • outbound.png
    outbound.png
    30 KB · Views: 6

voipBull

Member
Dec 3, 2023
53
8
8
@michelerizzo88 Usually carriers follow the below order of preference for caller ID (Atleast North_American carriers)
1/ P-Asserted ID header
2/ Remote-Party-ID header
3/ From header

In your case. you are atleast sending the R-P-ID header correctly (0832139XXXX for name and number - I'm assuming its correct) which looks like your carrier is not honoring if the callee end does not see this. You can try to switch to P-Asserted ID header by editing your Gateway on your FusionPBX > Expand the Advanced settings > Add 'pid' as a value for 'Sip CID Type' > then save. You'll probably need to stop/flush cache under SIP status/restart your Gateway for the change to take effect.

If the caller ID showing on the callee end is still your gateway number, then most likely your carrier has statically set your caller ID to your gateway number. You'll need to then work it out with your carrier.
 
Status
Not open for further replies.