reconnecting to gateway

haglo

New Member
May 14, 2021
8
0
1
60
My FreeSWITCH actual version has a public IP.
I have connected this FrreSWITCH with a gateway for Inbound-Calls & Outbound-Calls. It works.
But my FreeSWITCH loose sometimes the connection to the gatewas.
My questions:
1) is there a commant in fs_cli to reconnect the gateway
2) which setting must i make that there will be no diconnecting


My actual settings in conf/sip_profiles/external.xml
XML:
<profile name="external">
  <aliases></aliases>
  <gateways>
    <gateway name="gateway01">
      <param name="realm" value="xxxxxxxx"/>
      <param name="register-proxy" value="xxxxxxxx"/>
      <param name="username" value="xxxxxxxxx"/>
      <param name="password" value="xxxxxxxxx"/>
      <param name="register" value="true"/>
      <param name="sip-port" value="5060"/>
      <param name="caller-id-in-from" value="true"/>
      <!-- <param name="expire-seconds" value=""/> -->
      <param name="ping" value="10"/>
      <param name="context" value="public"/>
      <param name="extension" value="auto_to_user"/>
    </gateway>
  </gateways>
  <domains></domains>
  <settings>
    <param name="sip-ip" value="xxx.xxx.xxx.xxx"/>
    <param name="rtp-ip" value="xxx.xxx.xxx.xxx"/>
    <param name="ext-sip-ip" value="xxx.xxx.xxx.xxx"/>
    <param name="ext-rtp-ip" value="xxx.xxx.xxx.xxx"/>
    <param name="sip-port" value="5080"/>
    <param name="context" value="public"/>
    <param name="log-auth-failures" value="true"/>
  </settings>
</profile>

How must i change this settings, that there is no disconnecting to the gateway?
 
Last edited:

amalkabha

New Member
Jun 10, 2021
3
0
1
33
i have the same problem.
the sip provider says that is the problem because thier sbc(firewall) define a nat between us and the rgestration time is not equals.

they ask for 300 and i send 800.