SOLVED TIME CONDITIONS NOT EXECUTING AS EXPECTED

Status
Not open for further replies.

Andrew Byrd

Member
Feb 16, 2018
298
8
18
52
I have 3 parameters set up in Time Conditions. According to my set up, (based on time of day) the 2nd paramater should execute at 11:52am. Regardless of time of day, the 1st parameter (goes to billing voice mail) executes regardless of time of day

See attached - Can someone tell me what I did wrong?

Also, my other time condition I set went haywire today. As you can see from the other screenshot call calls right now, because right now it is Thursday 12:06pm, should be going to 801 entrance, but instead all calls are going to 605 answering.

Not sure what is happening. I have implemented time conditions before and have never had this issue.

UPDATE:

After further testing, the HOUR OF THE DAY seems to work successfully. It is when I choose TIME OF DAY that it does not work, totally disregards, and moves onto the next paramter

UPDATE

Upon further investigation I have a time issue that I am not sure of how to fix. At CLI in ssh, I run the date command and get the correct time. But when I run fs_cli the time entries are 6 minutes off. I do have the default time zone in fusion set to America New York. Not sure why server time, linux time and fusion time are correct, but in fs_cli the log entries are all 6 minutes behind.

Ok, from the fs_cli prompt, I ran
fsctl sync_clock

This fixed the time issue which made time conditions work properly
 

Attachments

  • Screenshot 2022-07-07 at 12-00-04 Time Condition - FusionPBX.png
    Screenshot 2022-07-07 at 12-00-04 Time Condition - FusionPBX.png
    43.7 KB · Views: 6
  • Screenshot 2022-07-07 at 12-05-40 Time Condition - FusionPBX.png
    Screenshot 2022-07-07 at 12-05-40 Time Condition - FusionPBX.png
    47.2 KB · Views: 5
Last edited:
Status
Not open for further replies.