Upgrade issue from 4.5.23 to 4.5.28

glennbtn

Member
Aug 7, 2018
30
1
8
50
Hi all

Having an issue with the upgrade to 4.5.28. Source works fine, schema and schema data types all good. When I go to run app defaults I get the following in the web browser

Fatal error: Uncaught Error: Call to undefined method database::table_exists() in /var/www/fusionpbx/app/conference_centers/app_defaults.php:42 Stack trace: #0 /var/www/fusionpbx/resources/classes/domains.php(763): include() #1 /var/www/fusionpbx/core/upgrade/index.php(102): domains->upgrade() #2 {main} thrown in /var/www/fusionpbx/app/conference_centers/app_defaults.php on line 42

If I try to run the upgrade from the command line I get

HP Fatal error: Uncaught Error: Call to undefined method database::table_exists() in /var/www/fusionpbx/app/conference_centers/app_defaults.php:42
Stack trace:
#0 /var/www/fusionpbx/resources/classes/domains.php(763): include()
#1 /var/www/fusionpbx/core/upgrade/upgrade.php(74): domains->upgrade()
#2 {main}
thrown in /var/www/fusionpbx/app/conference_centers/app_defaults.php on line 42

Fatal error: Uncaught Error: Call to undefined method database::table_exists() in /var/www/fusionpbx/app/conference_centers/app_defaults.php:42
Stack trace:
#0 /var/www/fusionpbx/resources/classes/domains.php(763): include()
#1 /var/www/fusionpbx/core/upgrade/upgrade.php(74): domains->upgrade()
#2 {main}
thrown in /var/www/fusionpbx/app/conference_centers/app_defaults.php on line 42

And ideas?