[SOLVED] postgres local replication script issue

yaboc

Member
Nov 23, 2017
96
7
8
35
hi,

when i run / rerun on primary node behind NAT with passwordless ssh between node1/2 and and all the firewall rules in place (script adds them too to local fw ) using external IPs

Code:
sh /var/www/fspbx/install/setup_logical_replication.sh

i get

Code:
Verifying PostgreSQL runtime settings on xx.xx.xx.11... 
PostgreSQL runtime settings verified on xx.xx.xx.11 
Verifying PostgreSQL runtime settings on xx.xx.xx.22... 
PostgreSQL runtime settings verified on xx.xx.xx.22 
Testing PostgreSQL connection from xx.xx.xx.11 to 127.0.0.1:5432... 
psql: error: connection to server at "127.0.0.1", port 5432 failed: FATAL:  password authentication failed for user "fusionpbx"
connection to server at "127.0.0.1", port 5432 failed: FATAL:  password authentication failed for user "fusionpbx"
PostgreSQL connection from xx.xx.xx.11 to 127.0.0.1:5432 failed. Verify the target server's 'fusionpbx' database password and network access.

This is with the latest 1.9.9 from installation script.
 
Likely causes:
- Incorrect local database password. Possibly the remote server’s password, Linux password, or FS PBX login password was entered instead.

When you run the script, it asks you 4 questions:
1) current server IP
2) remote server IP
3) Current server database password
4) Remote server database password

You must provide the correct answers to all 4 questions.
 
  • Like
Reactions: yaboc
Likely causes:
- Incorrect local database password. Possibly the remote server’s password, Linux password, or FS PBX login password was entered instead.

When you run the script, it asks you 4 questions:
1) current server IP
2) remote server IP
3) Current server database password
4) Remote server database password

You must provide the correct answers to all 4 questions.
@pbxgeek i must've pasted something wrong since i reran it and it's now complete! Thank you so much!

Code:
CREATE SUBSCRIPTION
Subscription fspbx_subscription_b_to_a created on LOCAL.
Bi-directional logical replication is now set up between LOCAL and REMOTE.
 
  • Like
Reactions: pbxgeek