Adding new menu items not working

jbeltran

New Member
Jun 2, 2020
5
0
1
44
Hi all,

I am trying to add a new menu item without any luck. I add the item and add permissions to "user" group, but the new item doesn't appear. I logout and logon but no way. Any clue?

best regards thanks in advance
 

jbeltran

New Member
Jun 2, 2020
5
0
1
44
Yes, "user" group has access. I add a new menu item named "My extension" pointing to "/login.php" (just for testing) and I can see all the items except for that one.

menu_pbx.jpg
 

jbeltran

New Member
Jun 2, 2020
5
0
1
44
Taking a closer look to database, I can figure out which can be the problem:

If I select the "Logout" item (for example) in the database, I get the following :

Code:
-[ RECORD 1 ]---------+-------------------------------------
menu_item_uuid        | ef4f1c93-24ee-445d-8611-666eaccba75c
menu_uuid             | b4750c3f-2a86-b00d-b7d0-345c14eca286
menu_item_parent_uuid | 65266fc8-8b90-4ecd-97c7-bd8a4607f8d8
uuid                  | 0d29e9f4-0c9b-9d8d-cd2d-454899dc9bc4
menu_item_title       | Logout
menu_item_link        | /logout.php
menu_item_icon        | fa-sign-out-alt
menu_item_category    | internal
menu_item_protected   | false
menu_item_order       | 3
menu_item_description |
menu_item_add_user    | admin
menu_item_add_date    | 2020-09-16 11:52:39.535331+00
menu_item_mod_user    |
menu_item_mod_date    |
but if I select the new menu item, I see no "uuid" was generated during the insertion:

Code:
-[ RECORD 1 ]---------+-------------------------------------
menu_item_uuid        | ac9af04f-3c63-40ff-9865-8401f7c7f010
menu_uuid             | b4750c3f-2a86-b00d-b7d0-345c14eca286
menu_item_parent_uuid | 65266fc8-8b90-4ecd-97c7-bd8a4607f8d8
uuid                  |
menu_item_title       | My extension
menu_item_link        | /login.php
menu_item_icon        | fa-terminal
menu_item_category    | internal
menu_item_protected   | false
menu_item_order       | 4
menu_item_description |
menu_item_add_user    | admin
menu_item_add_date    | 2020-09-16 12:40:01.733349+00
menu_item_mod_user    |
menu_item_mod_date    |
¿Maybe a bug? Also tried to generate a uuid, but it did not work :(
 

jbeltran

New Member
Jun 2, 2020
5
0
1
44
Just for testing, if I select in the database the menuitems in "en-us", it works! How do you create menu items in diferent langs? Any howto?
 

jbeltran

New Member
Jun 2, 2020
5
0
1
44
Recreated a new menu in "es-cl" lang, but keeps inserting as "en-us" in the database....any clue?

menu_es-cl.jpg

menu_db.jpg

"My extension" is a menu item enabled on both menus (en-us and es-cl), but regardless in which menu I add a menu item, is inserted in "en-us" and obviously only displayed if I select it (our system needs to be multilingual)