SOLVED Auto provisioning

Status
Not open for further replies.
I had found one article on how to get auto device provisioning to work, unfortunately, it doesnt work..
http://inside-out.xyz/technology/auto-provisioning-an-aastra-ip-telephone-with-fusionpbx.html

"First you need to do is go to your web server and add a .htaccess file entry. If you are using my RPM's the correct path for this file is /var/www/html/.htaccess. Edit it and add the following lines:

RewriteEngine On
RewriteRule ^.*/provision/aastra.cfg$ fusionpbx/app/provision/index.php?file=aastra.cfg [QSA]
RewriteRule ^.*/provision/([A-Fa-f0-9]{12})(\.(xml|cfg))?$ fusionpbx/app/provision/index.php?mac=$1[QSA]"

however, the vanilla install does not have an htaccess file in the root web directory. using a grandstream gxp2160

has anyone gotten the device provisioning to work? if so can you point me at some documentation?
 

DigitalDaz

Administrator
Staff member
I had found one article on how to get auto device provisioning to work, unfortunately, it doesnt work..
http://inside-out.xyz/technology/auto-provisioning-an-aastra-ip-telephone-with-fusionpbx.html

"First you need to do is go to your web server and add a .htaccess file entry. If you are using my RPM's the correct path for this file is /var/www/html/.htaccess. Edit it and add the following lines:

RewriteEngine On
RewriteRule ^.*/provision/aastra.cfg$ fusionpbx/app/provision/index.php?file=aastra.cfg [QSA]
RewriteRule ^.*/provision/([A-Fa-f0-9]{12})(\.(xml|cfg))?$ fusionpbx/app/provision/index.php?mac=$1[QSA]"

however, the vanilla install does not have an htaccess file in the root web directory. using a grandstream gxp2160

has anyone gotten the device provisioning to work? if so can you point me at some documentation?
Have you enabled provisioning in advanced/default settings?
 
@derr12:

are you using a current default 4.2 / 4.3 installation on Debian 8 ?

I recently set up provisioning for my Yealink phones and didn't have to change any settings for the nginx web server.

These are the steps I did to get things working:

In the 4.2 installation I started with, the "enabled" setting in the provisioning section was missing completely and I had to add it by hand. See the comment made by DigitalDaz.

Once that was done, I was able to download the configuration files the phones would see using the download option on the devices page.
Does that work for you ? If it does, then everything should be fine on the server side.

If so, then make sure your phone is set to the correct URL - I have "https://[server-FQDN]/provision" in my phones. As I am using ssl, I also had to install the CA-Certificate on my phones.
Short note: My Fusion-PBX domain is identical to the server-FQDN

That was all I did to get basic provisioning up and running.
I must admit, that I have spent a few hours customizing the templates used to adapt them to my needs, but that is a different story.
 
Last edited:
@derr12:

are you using a current default 4.2 / 4.3 installation on Debian 8 ?

I recently set up provisioning for my Yealink phones and didn't have to change any settings for the nginx web server.

These are the steps I did to get things working:

In the 4.2 installation I started with, the "enabled" setting in the provisioning section was missing completely and I had to add it by hand. See the comment made by DigitalDaz.

Once that was done, I was able to download the configuration files the phones would see using the download option on the devices page.
Does that work for you ? If it does, then everything should be fine on the server side.

If so, then make sure your phone is set to the correct URL - I have "https://[server-FQDN]/provision" in my phones. As I am using ssl, I also had to install the CA-Certificate on my phones.
Short note: My Fusion-PBX domain is identical to the server-FQDN

That was all I did to get basic provisioning up and running.
I must admit, that I have spent a few hours customizing the templates used to adapt them to my needs, but that is a different story.

In my test setup my domain is just the public IP address for now. ill double check my url and make sure i can get the files downloaded. Appreciate the help guys, i wouldnt be able to do a proper assessment without your help!
 
Status
Not open for further replies.