Exchange EMail Setup.

Status
Not open for further replies.

Timothy J. McGary

New Member
Jul 21, 2017
18
1
3
67
I have been trying to get the email function working, to no avail. I am getting the following errors when I try ("domain" is a placeholder for the real name):

method: smtp
smtp_auth: true
smtp_from: voicefax@domain.net
smtp_from_name: Voice-Fax
smtp_host: mail.domain.net
smtp_hostname: mail.domain.net
smtp_password: [REDACTED]
smtp_port: 25
smtp_username: voicefax@domain.net


Connection

2024-02-06 17:34:52 Connection: opening to mail.domain.net:25, timeout=300, options=array ()
2024-02-06 17:34:52 Connection: opened
2024-02-06 17:34:52 SERVER -> CLIENT: 220 mail.domain.net Microsoft ESMTP MAIL Service ready at Tue, 6 Feb 2024 12:34:52 -0500
2024-02-06 17:34:52 CLIENT -> SERVER: EHLO mail.domain.net
2024-02-06 17:34:52 SERVER -> CLIENT: 250-mail.domainnet Hello [10.0.0.7]250-SIZE 37748736250-PIPELINING250-DSN250-ENHANCEDSTATUSCODES250-STARTTLS250-X-ANONYMOUSTLS250-AUTH NTLM250-X-EXPS GSSAPI NTLM250-8BITMIME250-BINARYMIME250-CHUNKING250-SMTPUTF8250 XRDST

Fatal error: require_once(): Failed opening required 'extras/ntlm_sasl_client.php' (include_path='.:/usr/share/php:/var/www/fusionpbx') in /var/www/fusionpbx/resources/phpmailer/class.smtp.php on line 491
 

hfoster

Active Member
Jan 28, 2019
674
80
28
34
You'll probably want to take the extras folder from the legacy 5.2 branch of PHPMailer:

as the supplied one with FusionPBX doesn't seem to include the entire thing:
/var/www/fusionpbx/resources/phpmailer

Alternatively, I think what you'll want to do is enable Basic Authentication on the Exchange Connector, ideally for TLS only.
 
Status
Not open for further replies.