SOLVED fs_cli time different than system time

Status
Not open for further replies.

Andrew Byrd

Member
Feb 16, 2018
309
10
18
54
I have a strange issue. The time in my default settings "time_zone" is correct

The time from cli in ssh is correct when I run date or time

But, when I run fs_cli all the log entries are 6 -7 minutes off.

Not sure why this is
-----------------------------------

UPDATE

From the fs_cli prompt, I entered

fsctl sync_clock

This fixed the time issue.

I assumed the time would automatically be correct based on my prior settings.
 

Attachments

  • Screenshot 2022-07-07 at 12-37-08 System Status - FusionPBX.png
    Screenshot 2022-07-07 at 12-37-08 System Status - FusionPBX.png
    35.7 KB · Views: 10
  • Screenshot 2022-07-07 at 12-39-07 Domain Setting - FusionPBX.png
    Screenshot 2022-07-07 at 12-39-07 Domain Setting - FusionPBX.png
    7.5 KB · Views: 8
Last edited:

ad5ou

Active Member
Jun 12, 2018
887
201
43
You can also use "fsctl sync_clock_when_idle" as a safer alternative.
I added a cron job so I don't have to worry about clock drifting.
Code:
* 9 * * * /usr/bin/fs_cli -x "fsctl sync_clock_when_idle" >/dev/null 2>&1
My system clock is set to UTC so the "9" hour is still in the middle of the night before most customers are using system and well after other maintenance jobs have completed.
 

mcs3ss2

Active Member
Sep 8, 2020
274
29
28
AU
@ad5ou is right, I had same issue.

Now I sync FS time with cron twice a day. working Ok for over 2 years now
 
Status
Not open for further replies.