IVR CallerID Prefix Not Working

Robert Birch

Member
Mar 16, 2017
81
1
8
49
I maybe doing something wrong, but I am trying to send a CallerID Prefix to an extension by setting the Caller ID Name Prefix option in the IVR page.

IVR.png

But it doesn't seem to get passed. If I check the call detail record, I don't see the prefix being added.

Am I missing something?

Thanks
 

mudasar321

Member
Apr 18, 2019
76
5
8
32
Hi, Did anyone get a change to take a look into this? It's not working. I'm at version 4.5.18.
 

Bifur

Member
Sep 13, 2020
70
4
8
34
I added a prefix to a test IVR and it did not prepend the caller id after choosing an option either. Is that the way it is suppose to work?
 

Robert Birch

Member
Mar 16, 2017
81
1
8
49
The only way I could get it to work, was to go to DialPlan Manager and select the entry for the IVR in question.
I then had to click the XML button and add the following line:

<action application="set" data="effective_caller_id_name=ENG#${caller_id_name}"/>
Where ENG is the prefix. Save it and it works. Issue is, if you modify the IVR, this addition will be lost, and you need to add the line in again.

This is on Fusion 4.4.8. I haven't tried/tested on 4.5 yet.

Thanks
 

Bifur

Member
Sep 13, 2020
70
4
8
34
For anyone else, I just tried this. It seems if you use a : (IE Test: ) as a prefix, then the prefix is not included. If I just did Test then the caller ID shows up Test#Caller ID info.

This is on 4.5