Linksys SPA94X template correction

If you're still on the ancient Linksys SPA devices you'll probably notice a lot of problems with the template.

Here's one that's an easy fix. The Linksys template right now won't honour the SIP transport setting in the gui. To change this modify line 385 from this:

<SIP_Transport_1_ group="Ext_1/SIP_Settings">{$sip_transport_1}</SIP_Transport_1_>

To this:

<SIP_Transport_1_ group="Ext_1/SIP_Settings">{$sip_transport_1|upper}</SIP_Transport_1_>

If anyone needs help with Cisco/linksys SPA templates let me know, I've found a few other things that are more specific to my use case.
 
Oh wait there's more.

The Linksys SPA will not honour it's own SIP port setting so you have to modify line 415 to the following if you want to use a custom port:

<Proxy_1_ group="Ext_1/Proxy_and_Registration">{$server_address_1}:{$sip_port_1}</Proxy_1_>

After that It'll work.