Opensips 3.0 + Freeswitch Integration

Status
Not open for further replies.

Instigata

New Member
Nov 13, 2020
15
1
3
48
Hi all.

Apologies if this is in the wrong place, been trying to integrate Opensips with Freeswitch by following this old guide:

https://www.opensips.org/Documentation/Tutorials-OpenSIPSFreeSwitchIntegration

I think I have managed to get the other stuff working alright. However, it seems that the user extensions aren't being pulled from the opensips database. When I run:
list_users group default

I get the following error:
2021-05-25 02:57:32.297372 [ERR] mod_lua.cpp:202 /usr/share/freeswitch/scripts/xml_handler.lua:40: attempt to index global 'params' (a nil value)
stack traceback:
/usr/share/freeswitch/scripts/xml_handler.lua:40: in main chunk
2021-05-25 02:57:32.297372 [ERR] mod_lua.cpp:270 LUA script parse/execute error!

I am using Opensips 3.0 on Amazon EC2. Any help would be appreciated.
 

Adrian Fretwell

Well-Known Member
Aug 13, 2017
1,461
393
83
I think it may be the if statement that is throwing the error:
Code:
--show param debug info
if (debug["params"]) then
        freeswitch.consoleLog("notice", "[xml_handler] Params:\n" .. params:serialize() .. "\n");
end


This should not be the case if the line above it is being evaluated correctly:
Code:
--set the debug level
debug["params"] = true;
 

Instigata

New Member
Nov 13, 2020
15
1
3
48
I think it may be the if statement that is throwing the error:
Code:
--show param debug info
if (debug["params"]) then
        freeswitch.consoleLog("notice", "[xml_handler] Params:\n" .. params:serialize() .. "\n");
end


This should not be the case if the line above it is being evaluated correctly:
Code:
--set the debug level
debug["params"] = true;
Herein lies the mystery - or did I misunderstand your comment :)
 
Status
Not open for further replies.