Phonebook (Only supports Yealink currently)

I have fusionpbx 4.4.3 and I have install phonebook 4.4 but when I put http string on yealink have an error, seems not to recognize the api key that I have generate when I have make new user on fusionpbx, I see permission on fusionpbx and are enabled for user.
How can I fix it?
 
To be honest, I don't much care on it, but if it matters to someone - will do!
Error log are empity, access log contain:
[06/Dec/2018:06:59:52 +0100] "GET /app/phonebook/directory.php?gid=ac2d7ec1-a25e-44c6-8255-cb58c2894cd7 HTTP/1.1" 302 5 "-" "Yealink SIP-T58 58.83.0.5"
[06/Dec/2018:06:59:52 +0100] "GET /login.php?path=%2Fapp%2Fphonebook%2Fdirectory.php%3Fgid%3Dac2d7ec1-a25e-44c6-8255-cb58c2894cd7 HTTP/1.1" 200 8563 "-" "Yealink SIP-T58 58.83.0.5"
[06/Dec/2018:08:49:36 +0100] "GET /core/menu/menu.php HTTP/1.1" 302 5 "https://192.168.1.172/app/phonebook/phonebook.php" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0"
 

markjcrane

Active Member
Staff member
The included phone book uses FusionPBX contacts. Multiple things will be using contacts including new Messages application. Sending a FAX already uses it and more things are coming. So eventually you might start thinking that alternative phone books make it so you have to maintain more places for the same information.
 
The included phone book uses FusionPBX contacts. Multiple things will be using contacts including new Messages application. Sending a FAX already uses it and more things are coming. So eventually you might start thinking that alternative phone books make it so you have to maintain more places for the same information.
@Marc how do I get the remote phone book onto my yealink phone?
 
Darren,
Thank you for having such useful comments and solutions. I am anxious to try the phone book.

However, I was wondering if you could show that how-to video in a more useful resolution. I simply cannot make out what is on your screen, even if I change resolutions or try to zoom in.

Thanks.
 

markjcrane

Active Member
Staff member
hello to all, would it be possible to activate the import for version 4.4 because I have 4000 contacts to import for a client? How can I do?
Thank you
I will not be back porting the import to FusionPBX 4.4. Its available on master if you aren't willing to use Master then we are putting our efforts on master branch so it can be released and so that 4.4 can be deprecated sooner. FusionPBX 4.4 has weaker security so I'm not recommending 4.4 to anyone. Master branch is safer for security than 4.4 which is why new installs are using it.
 
Last edited: