Problem with 1 extension...


Sorry for the silley question but I just encountered an issue with my fusionpbx. I have one extension that keeps going to music on hold when you call it. For example:

extension 100 -> calls -> extension 102 -> answered with MOH

Now I have checked all the settings on the extension, there are no follow me, or MOH configured on it, it has been working for many month, now when I check the log in the console I see that the call is fowarded to fifo:VISA@ see the log bellow:

59dae7e6-3275-41da-a47a-b1f715e9869c 2018-04-23 09:32:37.967366 [DEBUG] switch_core_media.c:7180 sofia/internal/100@ Set 2833 dtmf send payload to 101
59dae7e6-3275-41da-a47a-b1f715e9869c 2018-04-23 09:32:37.967366 [DEBUG] switch_core_media.c:7187 sofia/internal/100@ Set 2833 dtmf receive payload to 101
59dae7e6-3275-41da-a47a-b1f715e9869c 2018-04-23 09:32:37.986813 [DEBUG] switch_core_media.c:7210 sofia/internal/100@ Set rtp dtmf delay to 40
59dae7e6-3275-41da-a47a-b1f715e9869c 2018-04-23 09:32:37.986813 [DEBUG] mod_sofia.c:850 Local SDP sofia/internal/100@
59dae7e6-3275-41da-a47a-b1f715e9869c v=0
59dae7e6-3275-41da-a47a-b1f715e9869c o=FreeSWITCH 1524445639 1524445640 IN IP4
59dae7e6-3275-41da-a47a-b1f715e9869c s=FreeSWITCH
59dae7e6-3275-41da-a47a-b1f715e9869c c=IN IP4
59dae7e6-3275-41da-a47a-b1f715e9869c t=0 0
59dae7e6-3275-41da-a47a-b1f715e9869c m=audio 19518 RTP/AVP 8 101
59dae7e6-3275-41da-a47a-b1f715e9869c a=rtpmap:8 PCMA/8000
59dae7e6-3275-41da-a47a-b1f715e9869c a=rtpmap:101 telephone-event/8000
59dae7e6-3275-41da-a47a-b1f715e9869c a=fmtp:101 0-16
59dae7e6-3275-41da-a47a-b1f715e9869c a=ptime:20
59dae7e6-3275-41da-a47a-b1f715e9869c a=sendrecv
59dae7e6-3275-41da-a47a-b1f715e9869c m=video 0 RTP/AVP 19
59dae7e6-3275-41da-a47a-b1f715e9869c 2018-04-23 09:32:37.986813 [DEBUG] sofia.c:7084 Channel sofia/internal/100@ entering state [completed][200]
59dae7e6-3275-41da-a47a-b1f715e9869c 2018-04-23 09:32:37.986813 [NOTICE] mod_dptools.c:1312 Channel [sofia/internal/100@] has been answered
59dae7e6-3275-41da-a47a-b1f715e9869c 2018-04-23 09:32:37.986813 [DEBUG] switch_channel.c:3773 (sofia/internal/100@ Callstate Change RINGING -> ACTIVE
59dae7e6-3275-41da-a47a-b1f715e9869c EXECUTE sofia/internal/100@ fifo(VISA@ in)
2018-04-23 09:32:37.986813 [DEBUG] mod_local_stream.c:871 Opening Stream [default/8000] 8000hz
59dae7e6-3275-41da-a47a-b1f715e9869c 2018-04-23 09:32:37.986813 [DEBUG] switch_ivr_play_say.c:1498 Codec Activated L16@8000hz 1 channels 20ms
59dae7e6-3275-41da-a47a-b1f715e9869c 2018-04-23 09:32:38.286806 [DEBUG] sofia.c:7084 Channel sofia/internal/100@ entering state [ready][200]
59dae7e6-3275-41da-a47a-b1f715e9869c 2018-04-23 09:32:38.487339 [DEBUG] switch_rtp.c:7308 Correct audio ip/port confirmed.
59dae7e6-3275-41da-a47a-b1f715e9869c 2018-04-23 09:33:03.846804 [NOTICE] switch_ivr.c:4269 Hangup sofia/internal/100@ [CS_EXECUTE] [NORMAL_CLEARING]

Could anyone be kind and shed some lights?
Thank you kindly
Hi, sorry for my late reply. @Andrew Yes I did and for some reason it does not help as, as soon as you re-create the same extension some how it brings the problem back in! @Digidaz There are no queues created and the call parking is disabled as well as the call forward. Now since then I had another extension with more or less the same issue, both extensions can make calls out internally and externally but cannot receive any calls, one will be redirected to MOH and the other nothing, no MOH or ringing! Anyway to cut a story short I ended up creating a new extension number for both these users and just banning 107 and 102, to get my users able to receive calls! If anyone ever come across that issue and find a fix for it please do let me know. Just for info I deleted these extensions 3 days ago so that my users could work, but, yesterday I tried re-creating 102, and the problem re-appeared on that extension, so I can reproduce that issue anytime if need be... Thank you for your help, so for now I have a work around...
Hi guys and sorry for the delay, but I was pushed by my boss to fix this issue! And I am happy to report that I have shade a lot of lights into this problem, actually solved it :-D and I am also happy to say that the problem was not with fusionpbx, but instead was with my ISP! and to be precise the actual router from my ISP was the problem. So, not only the router was faulty, in terms of not routing properly (a bug) but my ISP does not support SIP on their network, so what was happening is that while a wired extension connected to the router was connecting to our cloud server without any problem (SIP authentication) and you could make outgoing calls, it was not allowing inbound calls, thus disconnecting the extension and hence diverting the extension to either MOH or busy ring tone, now what is interesting is that this issue did not happen on wireless connected devices such as mobile phones. Now many time I have asked my ISP to provide a trace, but to date they still refuse (it would have been nice to share the root cause of the problem), I guess they are in the process of removing SIP connection on their network! In any case suffice to say that after their little stunt with my boss we decided to change ISP completely and making sure that SIP was fully supported. So all is back working again, if anyone get the same same issue, don't do what I did, which is assume that Fusionpbx is the problem (Ooops! sorry) and investigate your ISP in the first instance... @DigitalDaz thanks for your help and your willingness to assist remotely...