Raspberry Pi 3 Install Errors

RonR

New Member
=====
W: Failed to fetch http://packages.dotdeb.org/dists/jessie/InRelease Unable to find expected entry 'all/binary-armhf/Packages' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.
=====

=====
Configuring PHP
version 7.0
sed: can't read /etc/php/7.0/fpm/php.ini: No such file or directory
sed: can't read /etc/php/7.0/fpm/php.ini: No such file or directory
Failed to restart php7.0-fpm.service: Unit php7.0-fpm.service failed to load: No such file or directory.
=====

=====
psql: FATAL: database "fusionpbx" does not exist
psql: FATAL: database "fusionpbx" does not exist
CREATE DATABASE
CREATE DATABASE
CREATE ROLE
CREATE ROLE
GRANT
GRANT
GRANT
Failed to restart php7.0-fpm.service: Unit php7.0-fpm.service failed to load: No such file or directory.
=====

Are the errors above expected on an armhf install and can they be safely ignored?

Installation is being accomplished by running the following on a fresh Raspbian Jessie Lite image:

wget -O - https://raw.githubusercontent.com/fusionpbx/fusionpbx-install.sh/master/debian/pre-install.sh | sh
cd /usr/src/fusionpbx-install.sh/debian && ./install.sh

I also tried:

wget -O - https://raw.githubusercontent.com/fusionpbx/fusionpbx-install.sh/master/debian/pre-install.sh | sh
cd /usr/src/fusionpbx-install.sh/debian && ./install.sh --use-switch-package-unofficial-arm

but the addition of ' --use-switch-package-unofficial-arm' appeared to have no effect whatsoever.
 
Last edited:

RonR

New Member
However, should you choose to reinstall, I have just submitted a pull request which will give PHP 7 and Postgresql 9.6

https://github.com/fusionpbx/fusionpbx-install.sh/pull/93

We just need to wait for it to be committed,
Thank you very much for submitting the changes. I would like to get a clean install before proceeding.

How long does it normally take for such changes to be incorporated and how will I know they've been completed?
 

RonR

New Member
The commit has now been merged :) You are good to go.
Thanks for the notification.

=====
Processing triggers for libc-bin (2.19-18+deb8u7) ...
Processing triggers for systemd (215-17+deb8u6) ...
psql: FATAL: database "fusionpbx" does not exist
psql: FATAL: database "fusionpbx" does not exist
CREATE DATABASE
CREATE DATABASE
CREATE ROLE
CREATE ROLE
GRANT
GRANT
GRANT
Correct CPU and Operating System detected, using the ARM repo
ALTER ROLE
ALTER ROLE
INSERT 0 1
INSERT 0 1
INSERT 0 1


Installation has completed.
=====

Assuming the two 'psql: FATAL: database "fusionpbx" does not exist' lines above are expected, everything looks good now in the installation script output.