rport not working

Not open for further replies.


New Member
Jun 7, 2022
I am trying to connect to a gateway through the `internal` profile, on an FusionPBX server without a public ip address. I can connect to the gateway from a SIP soft client, but have trouble doing the same from FusionPBX.

On comparing the SIP traces from the soft client and freeswitch, I can see that the client is rewriting the port in the `Contact` and `Via` headers for subsequent register requests with the received ip and rport. I have been trying to configure the same in FusionPBX without avail.

I have already tried the following without success.

Under SIP Profiles > internal

  • Set `NDLB-force-rport` for the `internal` used by the gateway to `safe` and `true`. Neither worked.
  • Set `NDLB-received-in-nat-reg-contact` to `true`
  • Set `sip-force-contact` to `NDLB-connectile-dysfunction` and `NDLB-connectile-dysfunction-2.0` and `nat-connectile-dysfunction`

Under `Advanced > Variables > SIP Profile: Internal`
  • Add variable named `sip-force-contact`
How can I force FreeSwitch to rewrite `Contact` and `Via` with rport?
Last edited:
Not open for further replies.