SPA3102 Provisioning Failed

Edson

Member
Aug 1, 2017
40
3
8
43
Dear,

I am trying to place auto provisioning on SPA3102 but it is failling. SPA3102 is not sending username/password credentials to FusionPBX webserver. Is SPA3120 able to send this kind of information on response to a webserver challenge?
I used this line on Profile Rule config:

[--uid myUser --pwd myPass]http://mydomain.com/app/provision/?mac=$MA

Regards,

Edson
 

bcmike

Active Member
Jun 7, 2018
193
25
28
49
Hi,

This is what should be in your profile rule after provisioning is complete: [--uid myUser --pwd myPass]http://mydomain.com/app/provision/?mac=$MA

This is what you would put in a browser to provision the phone: http://IP ADDRESS OF PHONE/admin/resync?[--uid+myUser+--pwd+myPass+]http://fpbx1.local/app/provision/?mac=$MA

IP ADDRESS OF PHONE is the local ip of your phone
myUser is the username you set in fusionpbx for web based provisoning
myPass is the password you set in fusionpbx for web based provisoning

You can use ngrep on your FusionPBX server to see your progress and any error messages with this command: ngrep -d eth0 port 80 -W byline

As usual check your firewall rules, etc...

Good luck, I've only done this on SPA5xx phones and I've found the templates to be a little sketchy at times.
 

Edson

Member
Aug 1, 2017
40
3
8
43
Dear BCMIKE,

Thanks a lot!

I followed all this procedure you mention above. Linksys SPA3120 is not sending to the FusionPBX the username/password credentials into the GET messages requests. So the server answers with a 401 Authorization Required challenge message. finally, the Linksys ATA does not answer this challenge and the connection is closed.

Regards,

Edson
 

Attachments

bcmike

Active Member
Jun 7, 2018
193
25
28
49
I checked again and that's the exact URL syntax I use on my SPA phones. Maybe try it without http auth and see if it provisions properly just so you know that part of it works.

Also try putting the URL directly into your browser and make sure it works ie: http://FUSION PBX DOMAIN/app/provision/MAC ADDRESS OF PHONE

If that all works then I guess the 3120 just doesn't know how to process the mysuer and pwd options. Last but not least make sure the firmware is the latest.
 

Edson

Member
Aug 1, 2017
40
3
8
43
I checked again and that's the exact URL syntax I use on my SPA phones. Maybe try it without http auth and see if it provisions properly just so you know that part of it works.

Also try putting the URL directly into your browser and make sure it works ie: http://FUSION PBX DOMAIN/app/provision/MAC ADDRESS OF PHONE

If that all works then I guess the 3120 just doesn't know how to process the mysuer and pwd options. Last but not least make sure the firmware is the latest.
Dear BcMike,

Thanks again!

1-Yes, if I disable Http authentication on Fusion side, the SPA31020 is able to get the provision XML file.
2-Yes, if i put the url directory into my browse, the HTTP authentication works properly.
3-Yes, spa3120 is running under the latest firmware version, as i know.
4- I guess 3120 is not able to handle myuser/pwd options. Could you please tell me if SPA500 sends the intial HTTP Get message with myuser/pwd options inside it?

Regards,

Edson