SOLVED voip.co.uk / Firstcom Europe in the UK

Status
Not open for further replies.
Hi all, does anyone have experience of setting up with voip.co.uk / Firstccom Europe in the UK?
I've used this provider for a while but this is my first time setting up using FusionPBX.

The provider requires you to register for inbound and authenticate with a username and password for outbound.
I've attached my first set of settings for the Gateway but it remains in a Stopped status. I've tried it with firewalld running and not running.
I've put some best guesses in some of the advanced fields but the Gateay remains in a stopped state. I'm starting to wonder if it's the Gateway settings or if I've missed something somewhere. This was a straight install on CentOS 7.

If
 

Attached Files:

DigitalDaz

Administrator
Staff member
It should just work, make sure you have nothing in the hostname field.

Remaining in stopped state usually means an error that you may well see in the fs_cli logs

Centos could potentially be causing the problem too.
 
Ok, I have one more question please.

This provider provides incoming destination/DDI information in a weird way. Instead of providing the DID in the DID value it provides the SIP account username. The DDI data is in the SIP To: part of the header. This is the Asterisk code I use to extract the correct DDI and then pass the call on:

[custom-get-did-from-sip]
exten => _.,1,Noop(Getting DID from SIP header)
exten => _.,n,Set(pseudodid=${SIP_HEADER(To)})
exten => _.,n,Set(pseudodid=${CUT(pseudodid,@,1)})
exten => _.,n,Set(pseudodid=${CUT(pseudodid,:,2)})
exten => _.,n,Goto(from-trunk,${pseudodid},1)

Is there a way to manipulate the incoming header to extract this information in FusionPBX? I tried adjusting caller-details in the Dialplan section but it didn't make a difference.
 
Ok, after being dug out of a hole by @KonradSC I now have inbound calls working!

Here are the Gateway settings, with [Advanced] selected:
Gateway: <Your gateway name>
Username: SIP AOR Username
Password: SIP AOR Password
Proxy: single-01.proxy.voip.co.uk
Register: True
Auth User Name: SIP AOR Username
Extension: auto_to_user <- This is the magic bit KonradSC added
Outbound Proxy: single-01.proxy.voip.co.uk
CallerID in From: True
Domain: Your chosen domain
Context: Public
Profile: External
Enabled: True
Description: <Description of your gateway>

I also set up the IP's of voip.co.uk's SBC's in domains:

Advanced Menu -> Access Controls
Click domains
Click on the + sign on the right to add each IP below:

Type: Allow
CIDR: 193.203.210.38/32
Domain: <blank>
Description: voip.co.uk proxy 1
[Save]

Type: Allow
CIDR: 193.203.210.39/32
Domain: <blank>
Description: voip.co.uk proxy 2
[Save]

Type: Allow
CIDR: 193.203.210.29/32
Domain: <blank>
Description: voip.co.uk proxy 3
[Save]

[Save] again

If you have any questions don't hesitate to get in touch so I can pay it forward. Thanks @KonradSC you are a star and I owe you one!
 
Status
Not open for further replies.