SOLVED Call detail records not showing on new server installation

Status
Not open for further replies.

MKNGRP

Member
Mar 26, 2021
40
0
6
42
Hi there everyone -

I recently created a new fusionpbx server using Linux- Debian 10 ISO.
I added 3-5 multi tenant domains which work perfectly.
I realized yesterday that I could not see the CDR on any of the domains (Aside from one).
I have done the following:
1. Restarted freeswitch
2. Went to default settings and ensured that http enabled was set to true.
3. Group manager -> XML CDR enabled for both super admin and admin (all the options)
4. Went to upgrade -> and upgraded the schema and data types
5. Advanced -> modules -> XML CDR = enabled
6. Saw a suggestion of running the command "Run curl 127.0.0.1" - it was stated that if I received text back that means my CDR is not being blocked anywhere. - I received text back.
7. Manually stopped and restarted the server.
8. During all of these tests, I was constantly flushing the cache, reloading ACL and reloading XML - in addition to rescanning both internal and external profiles.
Any help would be greatly appreciated … I am completely lost here.
Thanks a bunch!
 
Last edited:

MKNGRP

Member
Mar 26, 2021
40
0
6
42
Please ignore this thread - I have NO idea what happened but my assumption is that something I did above, solved the issue.
My intelligent self did not try to test after implementation - thinking that it would automatically generate all CDR'S but, that was not the case.
Now, upon testing - calls coming in are being recorded in the CDR.
Thanks everyone!
 
Status
Not open for further replies.