Grandstream Outbound Proxy

Maybe I am doing something wrong but I'm trying to use the provisioning function in Fusion on a multi-tenet system but having issues with registration (I belive because of outbound proxy setting).

I can get the phones to register manually using the domain for the SIP server and the actual pbx FQDN for the outbound proxy. However I can't get the outbound proxy to update with auto provision.

I've entered it in the default settings under outbound_proxy_primary
I've tried entering it also in the outbound_proxy_secondary
I also tried adding a new setting called outbound_proxy (which is what i saw referenced in the xml template. <P48>{$account.1.outbound_proxy}</P48>

None of the above work. Any ideas? I've tried a 2140 and 2160. I have a 2135 adn 2170 but haven't tried those yet.
 

ElecBoy

New Member
Hi,

You should be in the menu Maintenance -> Upgrade and Provision, in here you would put the User & Password you specified in "Default Settings" Tab, with this URL. voip.domain.com/app/provision (*voip.* May change depending in the subdomain you created.) Also rember to create the device you are going to provision in Account-> Devices.


1549751727796.png
 
Thank you for the response. Maybe I wasn’t clear. I have the auto provisioning working fine for everything except the outbound proxy setting. No matter what I do the outbound proxy will not update in the phone. Every other setting does update without issues. Since the outbound proxy is needed the device will not register unless I manually enter that one setting in the device.
 
Ok and the login should be ext@domain? It works with a proxy and the SIP server as the domain but not any other way that I tested. On a single domain server the FQDN for SIP server and ext for account works but not on a multi domain system. I must be missing something.
 
Ok but we have some domains with the same ext. Keep in mind the domain for the tenant might not be a FQDN and/or doesn not resolve to the pbx.

For example.

The pbx’s FQDN is pbx.mydomaing.com.

There are two tenants hosted on the pbx.

Tenant 1 domain is tenant1.local.

Tenant2 is tenant2.local.

They both have an ext 1000.

If the FQDN is the SIP server then the system can distinguish which tenant is trying to register.

This is for any phone and not just Grandstream. Some for Yealink and softphones.
 
Yes. I feel it is more secure. Maybe we will change that in the future but for now that is the plan and it works well. Just can’t get that setting to auto provision. The template does have the setting in it but doesn’t seem to pull the information correctly from the domain settings/variables.