Inbound Calls dropping instantly

gtnt

New Member
Aug 22, 2022
3
0
1
29
Hello all,

I'm quite new to FusionPBX but this website already helped me a lot.
The situation is as follows:
Before I deploy FP on my cloud servers I wanted to get familiar with it on a standard raspberry pi debian installation on my local network.
Webports and SIP Signaling Ports forwarded 1:1 (80, 443, 5060, 5080), lets encrypt enabled and I have a dyndns client running and pointing to my current ip with pbx.__.de
Calls between extension are working and so are calls from an internal user (extension) to a public phone number routed via my gateway.
SIP Trunk is my vodafone cable carrier and the gateway ofcourse is registered.

But I cannot receive calls from an external number over my gateway.
SIP trace is here.

Didn't change anything in my ip settings, maybe here is the problem...
And carrier ip is added in ACL and server was restarted afterwards and so on, like described
here and here.

The following line from the pastebin is probably worth mentioning:
6fd5e86f 2022-08-25 13:45:40.915267 74.60% [WARNING] switch_core_state_machine.c:684 6fd5e86f-e28e-4c68-9925-cb6a6de4b64f sofia/external/<external-smartphone-number>@sip.kabelfon.vodafone.de Abandoned

Thanks for any help in advance!

Best regards,
Lukas
 

Adrian Fretwell

Well-Known Member
Aug 13, 2017
1,206
290
83
It Looks like your PBX is asking the SIP trunk provider to authenticate when it receives the invite from the gateway. This does suggest an ACL issue. Also check in your external SIP profile that auth-calls is set to false. (No sure what the new defaults are for FP v 5).
 
  • Like
Reactions: gtnt

gtnt

New Member
Aug 22, 2022
3
0
1
29
@Adrian Fretwell your were right. auth-calls was set to true and now I get a rejection by ACL:
2022-08-25 15:36:25.523699 72.40% [WARNING] sofia.c:10669 IP 88.134.209.241 Rejected by acl "provider"
Here are my settings: like I said before, cache was flusched, ACL reloaded and the pi restarted too.
acl.PNG
Do you have any idea about this?

Edit: I just saw the difference in the naming: "provider" vs "providers".....
 
Last edited:

Adrian Fretwell

Well-Known Member
Aug 13, 2017
1,206
290
83
Hi Lukas,
In your screenshot the ACL name is "providers", this may be a Fusion V5 thing that I am not familiar with. What is the name of the ACL specified by apply-inbound-acl in your external profile?
 
  • Like
Reactions: gtnt

gtnt

New Member
Aug 22, 2022
3
0
1
29
Hi @Adrian Fretwell , as I mentioned in the "edit" in the last post the name from the ACL in the Screenshot "providers" had to be modified to "provider".
Now everything works! Tanks for helping, this was fast!

Best regards,
Lukas

- can be closed and marked as solved -