Call center agents, with follow-me

Dast

New Member
Nov 11, 2019
19
3
3
Australia
Hi all,

I have a call center queue setup using the "callback" type, where the agents are signed in all the time (they never signout).
The agent extensions also have "Follow-Me" enabled, whereby if their extension is not registered then it is diverted to their remote extension (on their cell phone).

Is it possible to have the call center queue honor the follow-me settings, so if an agent's extension is not registered then it will attempt to call their follow-me extension?

Thanks ^_^
 

markjcrane

Active Member
Staff member
Jul 22, 2018
275
87
28
45
Call Center Agents are defined with a bridge statement that sends the call directly to the extension. This means that follow me under the current version of FreeSWITCH mod_callcenter is not possible.
 

Dast

New Member
Nov 11, 2019
19
3
3
Australia
No, this question was recently asked. Search the forums.
I did search before posting, didn't find it. Just did another search, still found nothing. Any applicable search terms you could provide to help narrow the search would be helpful.

Call Center Agents are defined with a bridge statement that sends the call directly to the extension. This means that follow me under the current version of FreeSWITCH mod_callcenter is not possible.
Thank you, this is very helpful and to the point. Much appreciated.

It seems straight forward enough that I'll look into patching the mod_callcenter myself to fulfill this requirement.
 

gflow

Member
Aug 25, 2019
46
1
8
I've tested this and it won't work if you set the "Not Registered" value in Call Routing but the call centre does does ring the follow-me values just like setting "enterprise" in the ring groups it will call all follow-me numbers (although on my version 4.4.11 it doesn't call external numbers on the follow-me when called via a ring group or call centre queue, the callerID doesn't get set correctly).